D800(E) Problems

I received several reports from users having problems with a D800 or D800E. The camera seems to toggle between “PC” and normal mode after the camera has been detected. I am not sure why this is happening (and I don’t have a D800 yet to debug it myself). Is there anybody with a D800 or D800E who does not have this issue when using Sofortbild?

It would also be interesting to know whether people having this issue with their D800(E) see the same when using Camera Control Pro 2.

Update: It seems like the D800(E) firmware update does not solve this issue.

Update 2: With the latest update the issues on the D800(E) and D600 should be fixed.

Sorry that it took such a long time to fix that issue. I did not get my D800 until very recently and I was not able to debug bug this issue remotely.

Sofortbild v1.2.5 adds support for D4, D800 and D800E

Sofortbild v1.2.5 is available now on the website and the Mac App Store. Sorry for the delay, but I started to work full-time in the meantime (for a well know company in Cupertino) and am not allowed to add features to Sofortbild myself anymore. So instead a friend a mine added the support. Anyway, you can now use Sofortbild with your brand new Nikon cameras.

Updated website and Sofortbild download

I updated the website including the screenshot to reflect the latest version. I also created a new build of Sofortbild (v1.2.4) that includes all the features that have been available in the Mac App Store version for a while now.

This version still supports Mac OS X 10.5 and includes support for all camera models mentioned on the website (for older models you have to enable legacy support in the preferences window and then relaunch the app though).

Sofortbild 1.0.1

Sofortbild 1.0.1 is available for download. The new version is basically the beta version that was available since a few months now. It needs Mac OS X 10.5.0 or later including 10.6 and works with Nikon D3x, D3, D2xs, D2hs, D2x, D2h, D1x, D1h, D1, D700, D300, D200, D100, D90, D80, D70s, D70, D60, D50, D40x, D40 and D5000.

There are no new features besides the support for all remaining camera models. The GPS location is now shown at the correct position in the map in the inspector.

Please use the auto update feature of Sofortbild to install the latest version.

Help needed for Sofortbild support for missing camera models

Thanks everybody who tried the Sofortbild Beta. Unfortunately I could not really figure out what works and what not. So I compiled a new beta version of Sofortbild which prints several information. Please download the new beta, run it and then send me the output.

To do so, launch “Console” and filter for “Sofortbild”. Then clear the log. Launch Sofortbild and try several things. Then send me an email to support[AT]sofortbildapp.com using the subject “Sofortbild Beta” including a short description of what you did, the model of your camera, your system information and of course the output. If the application crashed please add the latest crash report as well.

Thank you very much in advance.